Home Blog PDFlib 9.3.1 and Block Plugin 5.31 available

PDFlib 9.3.1 and Block Plugin 5.31 available

06 Apr 21

PDFlib GmbH released a new maintenance version of its PDFlib, PDFlib+PDI, and PDFlib Personalization Server (PPS) product family. A new version of the PDFlib Block Plugin for use with PPS is also available. Updating to 9.3.1 is recommended and free for all users of PDFlib, PDFlib+PDI, and PPS 9.0 - 9.3 under active support.

Please download new packages at https://www.pdflib.com/download/pdflib-product-family/.

The PDFlib 9.3.1 maintenance release contains bug fixes and improvements as well as new features, including the following: 

  • Support for Linux on ARM64 and macOS on ARM64 (Apple Silicon)
  • Updated language bindings including Perl 5.32, PHP 8, and Ruby 3.0
  • Fixed problems with subsetting of specific OpenType CFF fonts
  • Improved handling of PDF/A and PDF/X border cases
  • Modified font usage for form field appearance
  • Improvements in Tagged PDF import, including correct import of tagged tables spanning multiple pages
  • Improvements in SVG import for certain graphical constructs
  • Dozens of other bug fixes and enhancements

This version can be used to check your application for deprecated API and PDF features.

Identifying and removing deprecated features from your application code is strongly recommended in order to avoid incompatibilities with future PDFlib versions. 

The PDFlib Block Plugin has been updated to version 5.31. It now supports the new 64-bit version of Acrobat DC on Windows.

An updated version of the PDFlib Cookbook with hundreds of programming samples will shortly be published. It adds several code topics and updates dozens of existing topics.

Please Contact Us if you have any questions.